Jun. 12th, 2017

marahmarie: my initials (MM) (Default)

ETA: asked.

--ask around for s2 to move (back to) Top link from $this->print_body(); to $this->print_module_section("two"); - specifically, it should land right after .module-section-two but still within the same code block. More specifically, it should land after .module-section-two but before <div style="clear:both"> in the HTML above the footer (find screencap showing exactly where, if you post this).

This could fail spectacularly, but based on what I see in the live HTML editor, if I move the link where I say it should work and it actually works, it'll clear the page entirely on resized/mobile CSS (and on pages with very little content, which it currently can't clear even with CSS hacks) and stay where I put it - a 3-for-1 which, so far, has not been doable any other way.

marahmarie: Cockroaches get cancer, too (cigarettes)

ETA3, 9-3-17: My request got a response nine weeks ago; I forgot to post it. The thing I describe as a bug is not a bug, though it still counts as "undesired behavior" in my case. Full response:

Both LiveJournal and Dreamwidth use the URL schema https://v.dreamwidth.org/FILE_IDENTIFIER/ACCOUNT_NUMBER for icons. If you look at your profile you will notice that 44057 is your account number. Typical browser behaviour uses the last section of the URL as the default filename, so all icons you save in this fashion will have a default filename of your Dreamwidth account number.

You might wish to consider making a suggestion (https://www.dreamwidth.org/site/suggest) regarding a tool for bulk downloading usericons, in order to make the process of saving icons easier.

But, you know, if I made a suggestion it wouldn't be for DW to create a bulk downloading tool; it would be for Dreamwidth to stop depending on "typical browser behaviour" like it's still 1999. But I don't have a diplomatic way to put that, so the hell with it.

ETA2, 6-14-17: Request filed.

ETA, next night: Definitely need to report or at least ask about this over in Support; I tested my page in Pingdom last night and both recent icons I used in posts came up with the same file number, again, which rules out my computer as the cause. Got a screencap of Pingdom reporting them as such.


In this delightful bug, if you go to the Upload icons page and right-click/Save Image As, any icon you choose saves with the same image name: 440557.png. I mean, they all do. This in Firefox latest on Windows 10; you're mileage may vary and if it does, I'd like it if you let me know (I do have other accounts I can test this in, which I have not done yet) before I file a support request, which is still a ways off.

Testing the Update page as I write this, if I click the icon next to my username in the upper right hand corner (using the default site skin, I think it's called Tropo) the file saves with the same name, 440557.png. So all the icon images have the same name. I mean, I *think* this counts as a bug, that all the icons have the same names/numbers, so I'm thinking of reporting it.

What I'm testing here is a different icon than my default to see if posts show different icons with the same image number as well (probably will; post Preview page shows the same image number on right-click/View Image); this post can also double as a reminder to report this, eventually.